The issue affecting deliverability of some CRM system-generated emails has been resolved. Our final sweep confirmed no other areas were impacted, and outbound candidate-facing emails were unaffected throughout. Deliverability has returned to normal. Thank you for your patience.
Resolved
The issue affecting deliverability of some CRM system-generated emails has been resolved. Our final sweep confirmed no other areas were impacted, and outbound candidate-facing emails were unaffected throughout. Deliverability has returned to normal. Thank you for your patience.
Monitoring
We have implemented a fix for the affected CRM system-generated emails and are now monitoring deliverability to confirm messages are reaching inboxes as expected. As a precaution, we are also carrying out a final sweep to check for any other areas that may have been impacted. Outbound candidate-facing emails remain unaffected throughout. We will confirm once the fix is fully verified.
Investigating
We are investigating reports that some CRM system-generated emails may be delivered to recipients' spam or junk folders rather than their inboxes. This does not affect outbound candidate-facing emails, which are sending and delivering as normal. We will provide an update as soon as we have more information.